Ryu's blog

開発などのインプット・アウトプットの場

FlutterのCocoapodsのアップデートに関するWarning

flutter doctorでCocoapodsに関するWarningが消えない件

iOSをほとんど触らなかったので問題なかったのですが、ずっと放置していたcocoapodsのアップデートのWarningを解決したので記事にしときます。

[!] iOS toolchain - develop for iOS devices (Xcode 10.1)
    • Xcode at /Applications/Xcode.app/Contents/Developer
    • Xcode 10.1, Build version 10B61
    • ios-deploy 1.9.2
    ! CocoaPods out of date (1.5.0 is recommended).
        CocoaPods is used to retrieve the iOS platform side's plugin code that responds to your plugin usage on the Dart side.
        Without resolving iOS dependencies with CocoaPods, plugins will not work on iOS.
        For more info, see https://flutter.io/platform-plugins
      To upgrade:
        brew upgrade cocoapods
        pod setup

このCocoapodsに関するwarnigが取れなかった。 書かれている通りに

$ brew update
$ brew upgrade cocoapods
$ pod setup

を行ってもこのWarningが取れなかった。

ちょっと調べてみると、Flutterの公式GitHubにも同じようなIssueが上がっていた。

github.com

上のIssueのComment通りに

sudo gem install cocoapods

をしたが、ここでも以下のエラーが出てきた。

Fetching: cocoapods-core-1.5.3.gem (100%)
Successfully installed cocoapods-core-1.5.3
Fetching: cocoapods-deintegrate-1.0.2.gem (100%)
Successfully installed cocoapods-deintegrate-1.0.2
Fetching: cocoapods-downloader-1.2.2.gem (100%)
Successfully installed cocoapods-downloader-1.2.2
Fetching: molinillo-0.6.6.gem (100%)
Successfully installed molinillo-0.6.6
Fetching: atomos-0.1.3.gem (100%)
Successfully installed atomos-0.1.3
Fetching: nanaimo-0.2.6.gem (100%)
Successfully installed nanaimo-0.2.6
Fetching: xcodeproj-1.7.0.gem (100%)
ERROR:  While executing gem ... (Gem::FilePermissionError)
    You don't have write permissions for the /usr/bin directory.

この解決策としてインストール場所を指定する。(which podとコマンドを打つと/usr/local/bin/podとなっているのがわかる。)

sudo gem install cocoapods -n /usr/local/bin/

これでWarningを取り除くことができた。